Magento and Adobe Commerce use outdated PHP library that has big issues with modern PHP like composer or 8.1:

PHP Fatal error: require(): Failed opening required ‘/var/www/html/magento/vendor/composer/../../registration.php’ (include_path=’/var/www/html/magento/vendor/magento/zendframework1/library:.:/usr/share/pear:/usr/share/php’) in /var/www/html/magento/vendor/composer/autoload_real.php on line 73

Fix: check composer.json file in the root. Most probably it is deffected.

--

--